首页 网站建设优化正文

wordpress后台更新、插件和设置页面出现502错误的解决方法

网站有近三个月的时候没有更新了,刚开始是自己太忙了,后来是因为自己太懒了。昨天重新整理了一下自媒体博客,把赵连奎博客搬家安装到万网服务器上。折腾了半天的时间,网站搬家后wordpress后台更新、插件和设置页面等都出现502错误。刚开始觉得是自己数据库的问题,自己还原了以前的数据库,还是出现这个问题。 

自己也从网上查找了很多解决方法,最终都没能解决掉。自己当时非常郁闷,甚至想过放弃这个自媒体博客,反正本身也没有什么流量。再想想自己曾经努力的更新,浪费了大量的时间和精力,真心不舍得。最终完美解决了wordpress后台更新、插件和设置页面出现502错误的问题,心情还是非常激动的。 

其实造成这个问题的原因是wdcp面板+nginx+php5.2版本引起的wordpress不兼容,就是说php版本过低造成的。只需要把服务器的php5.2版本升级到php5.3或者更高版本即可解决掉。虽然最新版本的wdcp支持多个php版本共存,但为了节省服务器资源和节约时间,建议大家直接把php5.2升级成相应的版本即可。我个人就是直接把php5.2升级到php5.3版本的,完美解决掉wordpress后台502的问题。

A、升级PHP5.3wget http://soft.laozuo.org/wdcp/php_up53.sh sh php_up53.shB 、升级PHP5.5wget http://soft.laozuo.org/wdcp/php_up55.sh sh php_up55.sh 官方升级方法: wget http://down.wdlinux.cn/in/php_up53.shsh php_up53.sh

注意输完以上指令后,记得点击回车键,不然无法运行的。另外就是升级时间比较长,一般需要10分钟的时间,升级过程中千万不要中断,避免出现不可预知的问题。当你看到"php update is OK"提示时表示升级顺利完成 ,大家可以去wdcp后台看看是不是已经升级成相应的php版本。

特别注意:wdcp上不要安装云锁,不然php版本升级不能成功。

通过wordpress后台更新、插件和设置页面出现502错误的解决,我发现其实wordpress很多问题网友们都经历过。遇到问题后,千万不要慌,逐一排查相应的问题即可。如果你服务器还是php5.2版本,那么新安装的wordpress程序后台也会出现相应的问题,大家在安装完wordpress程序后,一定记得检查网站前台和后台运行是否正常。 

 推荐阅读: 阿里云服务器打开wordpress网站提示建立数据库连接时出错网站打不开,万网ECS提示安全骑士agent离线

评论