首页 网站建设优化正文

万网ecs服务器wdcp中php5.2无法升级到php5.3的原因

这次把网站搬家到新的万网ecs服务器,出现了各种各样的问题。可能是太久没操作过了,也可能是很多程序都更新了,像wdcp的后台等。昨天本以为网站搬家后的问题都解决掉了,今天突然发现网站后台插件和更新页还是显示502错误。我自己就照着之前写的一篇wordpress后台更新、插件和设置页面出现502错误的解决方法来解决,本以为很容易就解决了,可是总是无法升级。 

 因为不懂php语言,看不懂代码是什么意思,自己也是折腾了好久才算解决掉这个问题。下面说一下万网ecs服务器wdcp中php5.2无法升级到php5.3的原因,希望能帮到大家。 在wdcp后安装了云锁功能。之前关注网站安全时,觉得云锁是一款安全防护软件,自己虽然不会用,安装上也没有什么妨碍。安装倒是很简单,直接在wdcp后台安装即可。有网友说wdcp中php5.2无法升级到php5.3就是因为开启了wdcp后台的云锁功能。直接使用后台的卸载却是无法卸载,倒是折腾了许久才把云锁关闭掉。

卸载命令:/usr/local/yunsuo_agent/uninstall 具体操作步骤: 1.执行卸载命令:/usr/local/yunsuo_agent/uninstall 2.重启服务器,这是wdcp后台依然显示云锁保护中 3.再次执行卸载命令 4.刷新wdcp后台,看看是不是提示“还未安装云锁” 注:如果无效,请执行两次命令再重启试试,总之我是已经卸载掉了


wdcp卸载云锁图

关闭wdcp后台的云锁功能后,php5.2还是无法升级。自己没有办法,只有把提示的错误make: *** [ext/iconv/iconv.lo]放在百度上慢慢搜索,最终竟然完美解决了。

make: *** [ext/iconv/iconv.lo] 错误 1
这时候可以执行以下命令:
wget http://down.wdlinux.cn/in/iconv_ins.sh
sh iconv_ins.sh
这个命令成功执行之后重新make就没问题了,接着执行php升级命令,这次你会看到php5.2就已经成功升级到5.3了。

其实关于wdcp的php版本升级,很多网友都不是很顺利,遇到的问题也各种各样的。如果真的找不到解决问题的办法,那么就只有重新安装服务器程序,先升级php版本,再建设网站了。

推荐阅读:网站更换新的万网ecs服务器所遇到的奇葩问题利用wdcp面板备份mysql数据库和还原数据库